Oil Consumption.

gldwing57

New Member
Messages
3
Reactions
0
#1
I had to add a quart of oil after only 500 miles is that normal? Its got 800 on it now and I haven't checked it yet Im hoping its just a break in thing.
 

HellcatMike

Active Member
Messages
268
Reactions
3
#2
Yes it happened to me as well. Should be fine after that. I would still keep an eye on it just in case.
 

RonHellcat

Active Member
Messages
130
Reactions
4
#3
Mine was a little low but not 1 quart.
 

John G.

New Member
Messages
13
Reactions
2
#4
Per the owner's manual, that is normal.
 

gldwing57

New Member
Messages
3
Reactions
0
#5
Thanks for replies guys.. I will keep an eye on it. I noticed something else on mine. When its cold and you 1st start it when you stand outside seems like there is an exhaust leak up near left side of engine but after it runs just a minute or so it goes away. Have any of you ever noticed this?
 

John G.

New Member
Messages
13
Reactions
2
#6
No, not on mine. If it sounds like an exhaust leak, it probably is. Since it goes away after a minute, I would guess the heat causes expansion and seals the leak.
 
Messages
139
Reactions
2
#7
Thanks for replies guys.. I will keep an eye on it. I noticed something else on mine. When its cold and you 1st start it when you stand outside seems like there is an exhaust leak up near left side of engine but after it runs just a minute or so it goes away. Have any of you ever noticed this?
Does not happen on mine.
 
Messages
1
Reactions
0
#8
I had to add a quart at about 500 miles and again at 1000 miles? I’ve also noticed some upper valvetrain clatter at startup momentarily but nonetheless doesn’t seem right. Going to do an oil analysis to see if anything abnormal shows up.
 

New Hellcat Posts



Top